TOROID-Protection

Toroid-Simulator

Stand: 06.10.08
Geräte-Liste: (aufgelistet gemäß Serien-Nummern):

1 = Prototyp, voll funktionsfähig: bei FEA, bleibt dort.
2 : bei FEA, hatte Carsten Eckelmann (Stand Mar. '07: wird noch dort gebraucht), FPGA V. 1.02(?)
3 : im Labor M.Werner, war in Saclay, FPGA V. 1.04
4 : im Labor M.Werner, hatte vorher Max Görler, war dann im Labor M.Werner, von 19.-24.09.08 von Abdallah für Tests benutzt, FPGA V. 1.04
5 : am 07.02.07 von Max nach Saclay geschickt, FPGA V. 1.02 (wurde für Tests des TPS in der Kryo-Halle benutzt)
6 : an Reinh. Neumann geliehen, jetzt hat Mark L. ihn und möchte ihn anwenden, evtl. mit neu zu schreibender Firmware (Stand 01/07); FPGA V. 1.04

Änderungs-Vorschläge :

  • Clock-LED soll nicht mehr vom Pegel des Clock-Signals abhängen; die LED soll bei jeder +Flanke der Clock ca. 50ms lang aufblitzen: geändert bei V 1.02
  • Im Error-Mode 3 (Aufwärts-Rampe) soll der Pegel beim Erreichen des max. Wertes nicht mehr auf -max. springen: korrigiert in V 1.02
  • Die Taster sollen entprellt werden, damit beim Einzel-Error-Mode nur beim Drücken ein Error erzeugt wird und nicht auch beim Loslassen. --> In V 1.04 wurde eine Entprellung eingebaut, die aber noch nicht in allen Fällen funktioniert.

Beobachtungen :

  • Beim Einschalten des Gerätes wird auf den Analog-Ausgängen zunächst ein ca. 500us langer Rampen-Impuls der Amplitude 2.3V und ca. 250ms später ein ca. 100ns langer Impuls der Amplitude -4V erzeugt (jeweils mit 50-Ohm-Abschluss gemessen). --> geändert in V.1.04 in der Weise, dass das FPGA nach Reset den Code für Spannung 0V an die DACs legt. Das Verhalten direkt nach dem Einschalten wurde nach der Änderung noch nicht getestet.
  • Sind zunächst keine Buchsen des Gerätes angeschlossen und man steckt den ersten LEMO-Stecker mit geerdetem Außenleiter auf, schaltet sich ungewollt der Dauer-Error-Mode ein. (Internes EMV-Problem) --> lag daran, dass der Geräte-Ground ein Potential von hochohmig 80V gegenüber Erde hatte. Wurde gelöst durch Reihenschaltung von Drossel und Widerstand zwischen Geräte-Ground und Gehäuse.
  • In der Einstellung 1 oder 2.25 MHz und "macro"(also 800us) wird regelmäßig alle 1..3 sec. ein Impuls zuviel erzeugt. --> korrigiert in V 1.04 (oder bereits in V 1.02?)
  • Bis einschließlich V 1.04: Wenn man mit dem Taster S1(?) einen Einzel-Error erzeugt und ihn dann schnell loslässt, schnappt er bei einigen Geräten kurzzeitig so weit zurück, dass er kurz den Kontakt für "Dauer-Error" berührt, dadurch wird "Dauer-Error" ungewollt eingeschaltet.
  • LED 15(?) leuchtet ständig, wenn keine Kabel an die Buchsen "TTL in" angeschlossen sind. Nachfrage beim Entwickler ergab, dass das ein Versehen ist, eigentlich sollen in diesem Fall alle LEDs aus bleiben.